texashuntingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
slickster, masked_rider, AwareWolf, marcdt, Will3
72029 Registered Users
Top Posters(All Time)
dogcatcher 110,791
bill oxner 91,416
SnakeWrangler 65,495
stxranchman 60,296
Gravytrain 46,950
RKHarm24 44,585
rifleman 44,461
Stub 43,844
Forum Statistics
Forums46
Topics537,602
Posts9,726,783
Members87,029
Most Online25,604
Feb 12th, 2024
Print Thread
Telos LRF issue #8965581 12/01/23 10:14 PM
Joined: Jan 2023
Posts: 9
E
Erie660 Offline OP
Green Horn
OP Offline
Green Horn
E
Joined: Jan 2023
Posts: 9

I upgraded my Helion 2 XP50 pro for the new Telos LRF. I’ve only had it a week and so far I do like it, especially the LRF. The issue I had was it froze up on me when I tried to power it down. It would not do anything and then the screen got really pixelated. It stayed like that for about a minute and finally shut down. I turned it back on and it seems to work but it was daylight and raining so it was hard to tell. This all happened when I had it plugged in and charging. Anyone else that has one experience this? Thanks

Re: Telos LRF issue [Re: Erie660] #8965672 12/02/23 12:27 AM
Joined: Nov 2007
Posts: 9,513
R
RiverRider Offline
THF Trophy Hunter
Offline
THF Trophy Hunter
R
Joined: Nov 2007
Posts: 9,513
I had a Thermion XG50 give up the ghost on me a while back...the failure mode might or might not have been similar to what you're seeing but I wouldn't even guess. What I can tell you is Pulsar (or Sightmark Corp., not sure how all that business works really) stepped up and really treated me right. You can contact them from their webpage under "support" and I'm sure they'll steer you right.


[Linked Image]

"Arguing with you always makes me thirsty."

-Augustus McRae
Previous Thread
Index
Next Thread

© 2004-2024 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3