texashuntingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
reynoldstx5, MossMade, Dion P, ccondon, Gerald Cuvillier
69443 Registered Users
Top Posters(All Time)
dogcatcher 109,607
bill oxner 90,101
SnakeWrangler 62,556
stxranchman 59,395
Gravytrain 44,716
RKHarm24 44,585
rifleman 44,461
BMD 41,232
Forum Statistics
Forums46
Topics604,754
Posts11,303,212
Members84,443
Most Online19,184
Feb 5th, 2020
Print Thread
Polaris Ranger 02 sensor #8431721 10/27/21 10:39 PM
Joined: Jul 2007
Posts: 559
G
grimreapor Offline OP
Tracker
OP Offline
Tracker
G
Joined: Jul 2007
Posts: 559
I have a code saying the 02 sensor is bad. Replaced it and and the check engine light won’t clear. Anyone had this problem or any ideas how to clear this code? It runs fine and don’t act like it has any issues but I don’t want to harm anything. Thanks in advance

Re: Polaris Ranger 02 sensor [Re: grimreapor] #8432131 10/28/21 11:44 AM
Joined: Sep 2011
Posts: 2,855
V
Vern1 Offline
Veteran Tracker
Offline
Veteran Tracker
V
Joined: Sep 2011
Posts: 2,855
Unhook the battery for a minute or two and it should reset.
If it doesn't, then you may need a vehicle specific code reader to clear it.

OR....It wasn't really the O2 sensor and Polaris thinks you just need to take it to the stealership anyway and spend your money.


Cheers,
Vern1
Texans since The Old 300 in 1824
NRA Lifetime Member
Previous Thread
Index
Next Thread

© 2004-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3