texashuntingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Muff, Byron Head, eatsleephunt55, mike rig, skysenderossurveys
70395 Registered Users
Top Posters(All Time)
dogcatcher 110,618
bill oxner 91,416
SnakeWrangler 63,922
stxranchman 59,968
Gravytrain 46,950
RKHarm24 44,585
rifleman 44,461
BMD 41,241
Forum Statistics
Forums46
Topics613,088
Posts11,371,013
Members85,395
Most Online19,184
Feb 5th, 2020
Print Thread
Polaris Ranger 02 sensor #8431721 10/27/21 10:39 PM
Joined: Jul 2007
Posts: 590
G
grimreapor Offline OP
Tracker
OP Offline
Tracker
G
Joined: Jul 2007
Posts: 590
I have a code saying the 02 sensor is bad. Replaced it and and the check engine light won’t clear. Anyone had this problem or any ideas how to clear this code? It runs fine and don’t act like it has any issues but I don’t want to harm anything. Thanks in advance

Re: Polaris Ranger 02 sensor [Re: grimreapor] #8432131 10/28/21 11:44 AM
Joined: Sep 2011
Posts: 2,924
V
Vern1 Offline
Veteran Tracker
Offline
Veteran Tracker
V
Joined: Sep 2011
Posts: 2,924
Unhook the battery for a minute or two and it should reset.
If it doesn't, then you may need a vehicle specific code reader to clear it.

OR....It wasn't really the O2 sensor and Polaris thinks you just need to take it to the stealership anyway and spend your money.


Cheers,
Vern1
Texans since The Old 300 in 1824
NRA Lifetime Member
Previous Thread
Index
Next Thread

© 2004-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3