texashuntingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Ground Contact, BoozeyBoy, Ddavis9013, BeoWolfHunter, Jack Duke
67107 Registered Users
Top Posters(All Time)
dogcatcher 103,839
bill oxner 71,685
stxranchman 56,283
SnakeWrangler 53,027
RKHarm24 44,585
rifleman 44,451
BMD 41,089
Gravytrain 38,310
Facebook
Forum Statistics
Forums45
Topics433,074
Posts6,515,146
Members67,107
Most Online19,184
Feb 5th, 2020
Print Thread
Polaris 300 Xpress prime to start #7905259 07/19/20 02:59 AM
Joined: Jul 2005
Posts: 1,638
S
Stump_jumper Offline OP
Pro Tracker
OP Offline
Pro Tracker
S
Joined: Jul 2005
Posts: 1,638
It is a 2 cycle. If i have not run it for a couple of days i have to prime it. Carb has been rebuilt, new fuel lines from switch to carb, filter is fairly new, and fuel tank switch replaced last year. I am thinking lines from tank to switch, filter, or maybe a defective switch valve. To me it seems to have an air lock preventing fuel from filling the bowl. Once i prime it runs great and will start after shutting down with no problems.


2017 Tundra 5.7 CM 4x4
2006 Champion 2200 Bay Boat
Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7905396 07/19/20 01:00 PM
Joined: Nov 2005
Posts: 4,048
D
DLALLDER Offline
Extreme Tracker
Offline
Extreme Tracker
D
Joined: Nov 2005
Posts: 4,048
Unless it is a electronic fuel injection, that is pretty normal procedure. I had an older Yamaha Grizzly that in cold weather you had to have the machine in full choke for the first 50-100 yds before it would run with being choked. It was a 4 stroke.







Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7905729 07/19/20 08:19 PM
Joined: Sep 2011
Posts: 2,663
V
Vern1 Offline
Veteran Tracker
Offline
Veteran Tracker
V
Joined: Sep 2011
Posts: 2,663
Does it have an electric fuel pump or a pulse pump?
If it has a pulse pump, the motor has to turn over a few times to pump any fuel - it works on alternating pressure/vacuum in the crankcase as motor spins.


Cheers,
Vern1
Texans since The Old 300 in 1824
NRA Lifetime Member
Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7906186 07/20/20 01:58 AM
Joined: Jul 2005
Posts: 1,638
S
Stump_jumper Offline OP
Pro Tracker
OP Offline
Pro Tracker
S
Joined: Jul 2005
Posts: 1,638
Not an electric pump. I checked fuel flow out of tank after filter and fine. I put a new filter on it anyway. Primed it cranked right up and idled for 10 minutes. Took it out for a spin and ran fine. I left gas on and 2 hours later ut cranked right up. Problem occurs when i leave fuel valve off. I am going to leave fuel valve on and crank daily.


2017 Tundra 5.7 CM 4x4
2006 Champion 2200 Bay Boat
Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7913065 07/25/20 10:14 PM
Joined: Jul 2005
Posts: 1,638
S
Stump_jumper Offline OP
Pro Tracker
OP Offline
Pro Tracker
S
Joined: Jul 2005
Posts: 1,638
I have left the gas valve on for a week. Fires right up NP every day. Not sure why i have to prime when i turn it off. I would add a primer bulb if i had room for one.


2017 Tundra 5.7 CM 4x4
2006 Champion 2200 Bay Boat
Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7919061 07/31/20 01:49 AM
Joined: Feb 2011
Posts: 1,280
B
Black Duck Dog Offline
Pro Tracker
Offline
Pro Tracker
B
Joined: Feb 2011
Posts: 1,280
Unless it’s leaking or flooding over leave the valve on. I never shut mine off Just my 2 cents

Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7919434 07/31/20 03:22 PM
Joined: Oct 2004
Posts: 33,877
R
redchevy Offline
THF Celebrity
Offline
THF Celebrity
R
Joined: Oct 2004
Posts: 33,877
What do you mean when you say prime? Id doesn't have a primer button and it doesn't have a bulb, how are you priming it?

When your shut the fuel off when you store it are you turning the valve off and letting it run out of fuel and die? Could be the fuel is evaporating out of the carb when you turn the shut off and the tank doesnt keep it full.


It's hell eatin em live
Re: Polaris 300 Xpress prime to start [Re: redchevy] #7919737 07/31/20 08:52 PM
Joined: Jul 2005
Posts: 1,638
S
Stump_jumper Offline OP
Pro Tracker
OP Offline
Pro Tracker
S
Joined: Jul 2005
Posts: 1,638
Originally Posted by redchevy
What do you mean when you say prime? Id doesn't have a primer button and it doesn't have a bulb, how are you priming it?

When your shut the fuel off when you store it are you turning the valve off and letting it run out of fuel and die? Could be the fuel is evaporating out of the carb when you turn the shut off and the tank doesnt keep it full.

I dump a little fuel straight in to the air filter box. I am going to do what Black Duck Dog. I was not running it dry. I did that with first Mercury i owned until i got smart and figured out it was not necessary.i think it is better for needles to stay wet.


2017 Tundra 5.7 CM 4x4
2006 Champion 2200 Bay Boat
Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7920995 08/02/20 01:06 PM
Joined: Jan 2016
Posts: 6,381
S
snake oil Offline
THF Trophy Hunter
Offline
THF Trophy Hunter
S
Joined: Jan 2016
Posts: 6,381
Sounds like the tank may not be vented properly.


"Hey, where the white women at?"
Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7922225 08/03/20 03:19 PM
Joined: Oct 2004
Posts: 33,877
R
redchevy Offline
THF Celebrity
Offline
THF Celebrity
R
Joined: Oct 2004
Posts: 33,877
Originally Posted by Stump_jumper
Originally Posted by redchevy
What do you mean when you say prime? Id doesn't have a primer button and it doesn't have a bulb, how are you priming it?

When your shut the fuel off when you store it are you turning the valve off and letting it run out of fuel and die? Could be the fuel is evaporating out of the carb when you turn the shut off and the tank doesnt keep it full.

I dump a little fuel straight in to the air filter box. I am going to do what Black Duck Dog. I was not running it dry. I did that with first Mercury i owned until i got smart and figured out it was not necessary.i think it is better for needles to stay wet.

Im not sure on my thoughts on that. Had a 3 cylinder/3 carb evinrude on our first boat from 1985-2014. We ran the gas out of it every time that boat came off the water. The carbs were never opened and it would still fire on the first crank when we sold it.

Recently acquired a riding mower and got my old generator running after sitting for some time, the needle on either of them wouldnt seal and they would flood till i rebuilt/replaced the carbs. Perhaps the 2-stroke pre mix in the evinrude saved it over its almost 3 decades.


It's hell eatin em live
Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7923232 08/04/20 11:48 AM
Joined: Dec 2006
Posts: 1,694
C
ChrisB Offline
Pro Tracker
Offline
Pro Tracker
C
Joined: Dec 2006
Posts: 1,694
I discovered my four wheeler has two filters inside the tank when you drop the fuel valve. They were restricting the fuel until there was a suction on them from the engine running.

Re: Polaris 300 Xpress prime to start [Re: ChrisB] #7923288 08/04/20 01:04 PM
Joined: Jul 2005
Posts: 1,638
S
Stump_jumper Offline OP
Pro Tracker
OP Offline
Pro Tracker
S
Joined: Jul 2005
Posts: 1,638
Originally Posted by ChrisB
I discovered my four wheeler has two filters inside the tank when you drop the fuel valve. They were restricting the fuel until there was a suction on them from the engine running.

I will look in my tank but i dont think there any filters in there. I disconnected the fuel line below filter and flow looks good. I am just going to leave the valve open.


2017 Tundra 5.7 CM 4x4
2006 Champion 2200 Bay Boat
Re: Polaris 300 Xpress prime to start [Re: Stump_jumper] #7923956 08/04/20 09:44 PM
Joined: Sep 2012
Posts: 11,043
P
PMK Offline
THF Celebrity
Offline
THF Celebrity
P
Joined: Sep 2012
Posts: 11,043
leaving the valve open should be fine as long as the float isn't stuck allowing fuel to run out. I've owned dozens of off road motorcycles over the last 50 years and that always worked fine ... I had one XR600 that the float was notorious for sticking open that I had to turn off the fuel, but leave it sitting a few weeks and it was a bear to start as the gas in the carb dried up clogging the jets.


"everyone that lives dies but not everyone who dies lived..."

~PMK~
Re: Polaris 300 Xpress prime to start [Re: snake oil] #7932967 08/12/20 07:40 PM
Joined: Jul 2005
Posts: 1,638
S
Stump_jumper Offline OP
Pro Tracker
OP Offline
Pro Tracker
S
Joined: Jul 2005
Posts: 1,638
Originally Posted by snake oil
Sounds like the tank may not be vented properly.

Vent is fine I just pulled the line out of the steering column and blew through it with gas cap off. I think it is a vacuum issue. I am going to replace the vacuum line that runs from the engine to the carb.


2017 Tundra 5.7 CM 4x4
2006 Champion 2200 Bay Boat
Previous Thread
Index
Next Thread

© 2004-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3