texashuntingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Boltgunner6.5, texags2012, NateS, No1skier, roo_ster
67119 Registered Users
Top Posters(All Time)
dogcatcher 103,844
bill oxner 71,782
stxranchman 56,283
SnakeWrangler 53,027
RKHarm24 44,585
rifleman 44,451
BMD 41,089
Gravytrain 38,352
Facebook
Forum Statistics
Forums45
Topics433,196
Posts6,516,741
Members67,119
Most Online19,184
Feb 5th, 2020
Print Thread
Feeder won't "sling"...barely spins. #7883818 06/28/20 05:45 PM
Joined: Aug 2017
Posts: 160
J
jadkins Offline OP
Woodsman
OP Offline
Woodsman
J
Joined: Aug 2017
Posts: 160
I have a 1 year old Lamco Low and Throw. Thing started off slinging corn prob.15 - 2- yards. Now it barely spins and most of the corn doesn't even make it off the varmint proof plate. I've changed battery and the Mr. Timer...same results. Only thing i haven't changed is wires and the motor. Thoughts?

I also posted this in feeder forum...sorry for the duplicity...figured more traffic here.

Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7883842 06/28/20 05:56 PM
Joined: Oct 2012
Posts: 16,169
Creekrunner Online Content
THF Celebrity
Online Content
THF Celebrity
Joined: Oct 2012
Posts: 16,169
You didn't let a feed sack string get down in there, did you? If not, I'd say it's the motor. Contact Lamco if possible.


...and have dominion over the fish of the sea, and over the fowl of the air, and over every living thing that moveth upon the earth. Gen. 1:28
Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7883855 06/28/20 06:05 PM
Joined: Jun 2015
Posts: 8,409
R
rickym Online Content
THF Trophy Hunter
Online Content
THF Trophy Hunter
R
Joined: Jun 2015
Posts: 8,409
Clean/ Spray some lube on the motor shaft. Your clogged up


See y’all around the campfire.

Originally Posted by Grizz
Wingshooting is like sex for me - I love doing it but I'm just not that good at it.

Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7883882 06/28/20 06:43 PM
Joined: Jul 2019
Posts: 2,815
H
Hudbone Online Content
Veteran Tracker
Online Content
Veteran Tracker
H
Joined: Jul 2019
Posts: 2,815
Creek is probably on it.

Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7884451 06/29/20 04:22 AM
Joined: Jul 2010
Posts: 252
C
CGB Offline
Bird Dog
Offline
Bird Dog
C
Joined: Jul 2010
Posts: 252
The spinner plate has a screw that keeps it attached to the motor shaft. I bet it’s loose and keeping it from spinning properly. This happened to a friend on mines. If that’s what’s wrong you’ll need to take 3 of the 4 bolts out that hold that bottom plate on. You should be able to lean it down enough to reach the spinner.

Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7884553 06/29/20 11:50 AM
Joined: Oct 2017
Posts: 794
A
angus1956 Online Content
Tracker
Online Content
Tracker
A
Joined: Oct 2017
Posts: 794
Bad motor replaced one last year.

Re: Feeder won't "sling"...barely spins. [Re: Creekrunner] #7884757 06/29/20 03:00 PM
Joined: Aug 2017
Posts: 160
J
jadkins Offline OP
Woodsman
OP Offline
Woodsman
J
Joined: Aug 2017
Posts: 160
Originally Posted by Creekrunner
You didn't let a feed sack string get down in there, did you? If not, I'd say it's the motor. Contact Lamco if possible.


We use bulk corn not sacks...so don't think its a string.

Re: Feeder won't "sling"...barely spins. [Re: CGB] #7884760 06/29/20 03:01 PM
Joined: Aug 2017
Posts: 160
J
jadkins Offline OP
Woodsman
OP Offline
Woodsman
J
Joined: Aug 2017
Posts: 160
Originally Posted by CGB
The spinner plate has a screw that keeps it attached to the motor shaft. I bet it’s loose and keeping it from spinning properly. This happened to a friend on mines. If that’s what’s wrong you’ll need to take 3 of the 4 bolts out that hold that bottom plate on. You should be able to lean it down enough to reach the spinner.


Thanks. I'll look into this.

Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7884977 06/29/20 05:47 PM
Joined: Jul 2006
Posts: 103,844
dogcatcher Online Content
THF Celebrity
Online Content
THF Celebrity
Joined: Jul 2006
Posts: 103,844
Try a drop of oil on the motor shaft to grease the bearings inside of the motor. Gravity will let it flow into the motor.


Combat Infantryman, the ultimate hunter where the prey shoots back.
_____________"Illegitimus non carborundum est"_______________

[Linked Image]
Re: Feeder won't "sling"...barely spins. [Re: CGB] #7886163 06/30/20 07:32 PM
Joined: Nov 2010
Posts: 1,267
S
Schpanky Online Content
Pro Tracker
Online Content
Pro Tracker
S
Joined: Nov 2010
Posts: 1,267
Originally Posted by CGB
The spinner plate has a screw that keeps it attached to the motor shaft. I bet it’s loose and keeping it from spinning properly. This happened to a friend on mines. If that’s what’s wrong you’ll need to take 3 of the 4 bolts out that hold that bottom plate on. You should be able to lean it down enough to reach the spinner.


^^^yes....check this....I've had this happen before...took me a while to figure out why my feeder wasn't feeding....the set screw will work loose and the shaft just spins inside the housing

Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7886188 06/30/20 07:53 PM
Joined: Jan 2013
Posts: 18,285
P
Pitchfork Predator Online Content
THF Celebrity
Online Content
THF Celebrity
P
Joined: Jan 2013
Posts: 18,285
Those motors rarely go bad.......


Marc C. Helfrich
Retirement Planner

www.insured-wealth.com
469-323-8920
Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7886237 06/30/20 08:34 PM
Joined: Aug 2010
Posts: 56,283
S
stxranchman Online Content
Obie Juan Kenobi
Online Content
Obie Juan Kenobi
S
Joined: Aug 2010
Posts: 56,283
I have had to replace 2 motors in the last 40 yrs. One had a bad spot and it would not do anything when you hit test till you rotated the spinner plate. Then it would spin till it stopped on the bad spot again. The other time was due to rain/moisture getting down the shaft into the motor...it would spin but slowly and you could hear it spin. Like posted above the spinner plates will work loose but you can hold the motor shaft and spin the plate on most to check it. One other things is the take the motor wires and touch them directly to the batter to see if it spins freely and like normal. Last step is to replace the motor.


[Linked Image]
Re: Feeder won't "sling"...barely spins. [Re: CGB] #7886883 07/01/20 01:25 PM
Joined: May 2013
Posts: 3,014
CharlieCTx Offline
Veteran Tracker
Offline
Veteran Tracker
Joined: May 2013
Posts: 3,014
Originally Posted by CGB
The spinner plate has a screw that keeps it attached to the motor shaft. I bet it’s loose and keeping it from spinning properly.


Have one doing this now, screw fell out and didn't have one with me.

Charlie


Kel-Tec RFB + Griffin Sportsman Ultra Light 300 + Pulsar Apex XQ-50
M&P-10 + AAC Cyclone
Remy 700 + Leupold VX3 3.5x10x50 CDS
Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7886953 07/01/20 02:18 PM
Joined: Jul 2008
Posts: 17,418
T
Texas Dan Online Content
THF Celebrity
Online Content
THF Celebrity
T
Joined: Jul 2008
Posts: 17,418
After looking for the issues mentioned earlier, a good way to verify if the problem is the motor or the control board is to use some extra wire and hot wire the motor directly to the battery. If the motor runs fine when connected to the battery, just replace the electronics with a new control board.

Last edited by Texas Dan; 07/01/20 02:19 PM.

Dan

Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7893223 07/07/20 06:06 PM
Joined: Aug 2017
Posts: 160
J
jadkins Offline OP
Woodsman
OP Offline
Woodsman
J
Joined: Aug 2017
Posts: 160
So...the spin plate actually broke loose from the screw assembly. So, the motor was spinning just fine and the assembly was still screwed tight to shaft, but the plate wasn't going anywhere...just kind of barely moving. Replaced the plate and assembly and it is slinging fine. Just a pain to replace with the predator plate and all. Thanks everyone.

JA

Re: Feeder won't "sling"...barely spins. [Re: jadkins] #7893345 07/07/20 07:52 PM
Joined: Jul 2010
Posts: 252
C
CGB Offline
Bird Dog
Offline
Bird Dog
C
Joined: Jul 2010
Posts: 252
Originally Posted by jadkins
So...the spin plate actually broke loose from the screw assembly. So, the motor was spinning just fine and the assembly was still screwed tight to shaft, but the plate wasn't going anywhere...just kind of barely moving. Replaced the plate and assembly and it is slinging fine. Just a pain to replace with the predator plate and all. Thanks everyone.

JA

Glad to hear you got it fixed. Did Lamco give you a new spinner plate? When we had issues their customer service was excellent. They sent us all kinds of stuff to fix it.

Previous Thread
Index
Next Thread

© 2004-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3