texashuntingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
HogNArrow, Wyohunter1, BMB163, harkm, Turtle Jeep
64368 Registered Users
Top Posters(All Time)
dogcatcher 90,174
stxranchman 53,762
bill oxner 49,824
RKHarm24 44,577
rifleman 44,414
BMD 41,009
SnakeWrangler 39,622
Big Orn 37,484
txshntr 35,378
Facebook
Forum Statistics
Forums45
Topics418,020
Posts6,076,932
Members64,368
Most Online16,728
Mar 25th, 2012
Print Thread
SPYPOINT link evo #7015054
12/29/17 12:28 AM
12/29/17 12:28 AM
Joined: Dec 2015
Posts: 109
Southeast TX
C
Codyd713 Offline OP
Woodsman
Codyd713  Offline OP
Woodsman
C

Joined: Dec 2015
Posts: 109
Southeast TX
Trying to figure out why the red light that reads Ďbusyí is lit up. The light is on the lower back side of the camera. Their website isnít very easy to troubleshoot. Status of the camera shows itís ready to go but itís not taking any photos. Anyone have a solution?

Re: SPYPOINT link evo [Re: Codyd713] #7015213
12/29/17 02:23 AM
12/29/17 02:23 AM
Joined: Feb 2010
Posts: 245
L
lmd59 Offline
Woodsman
lmd59  Offline
Woodsman
L

Joined: Feb 2010
Posts: 245
Send it back to them and it will fall into a black hole. Terrible customer service and crappy cameras.

Re: SPYPOINT link evo [Re: Codyd713] #7015287
12/29/17 03:17 AM
12/29/17 03:17 AM
Joined: Feb 2009
Posts: 5,232
Dallas
T
tannerlst Offline
THF Trophy Hunter
tannerlst  Offline
THF Trophy Hunter
T

Joined: Feb 2009
Posts: 5,232
Dallas
I don't like mine . Horrible quality pictures

Re: SPYPOINT link evo [Re: Codyd713] #7015476
12/29/17 12:54 PM
12/29/17 12:54 PM
Joined: Sep 2015
Posts: 52
SE Texas
P
Pootie Online content
Outdoorsman
Pootie  Online Content
Outdoorsman
P

Joined: Sep 2015
Posts: 52
SE Texas
Returned mine - when it did work (not often) crappy pics. Picked up a Bushnell Aggressor and am very happy with it.

Re: SPYPOINT link evo [Re: Codyd713] #7015542
12/29/17 02:00 PM
12/29/17 02:00 PM
Joined: Dec 2015
Posts: 109
Southeast TX
C
Codyd713 Offline OP
Woodsman
Codyd713  Offline OP
Woodsman
C

Joined: Dec 2015
Posts: 109
Southeast TX
Dang, not the responses I was hoping for but after reading other reviews, I kind of expected it.

Last edited by Codyd713; 12/29/17 02:01 PM.
Re: SPYPOINT link evo [Re: Codyd713] #7015685
12/29/17 03:58 PM
12/29/17 03:58 PM
Joined: Aug 2012
Posts: 602
Grand Prairie
D
Dien Offline
Tracker
Dien  Offline
Tracker
D

Joined: Aug 2012
Posts: 602
Grand Prairie
Never had a problem with mine. Firmware needed to be updated and they sent e-mail. Week before my unit wouldn't work because I didn't update it they called me twice from Canada to remind me.

Have you tried switching out the memory card as they go bad regularly on mine. Fresh batteries also.

Re: SPYPOINT link evo [Re: Codyd713] #7015712
12/29/17 04:21 PM
12/29/17 04:21 PM
Joined: Dec 2015
Posts: 109
Southeast TX
C
Codyd713 Offline OP
Woodsman
Codyd713  Offline OP
Woodsman
C

Joined: Dec 2015
Posts: 109
Southeast TX
Yeah I put brand new entergizer lithiumís in it and also tried two different new sd cards. Havenít received anything about updating firmware.

Re: SPYPOINT link evo [Re: Codyd713] #7015775
12/29/17 05:09 PM
12/29/17 05:09 PM
Joined: Nov 2011
Posts: 4,225
Keller
T
Texas buckeye Offline
Extreme Tracker
Texas buckeye  Offline
Extreme Tracker
T

Joined: Nov 2011
Posts: 4,225
Keller
I have had that issue twice on my camera. First time was when I first set it up, was not getting a signal so I got a cell booster antenna and it solved the problem.

More recently I had the same thing happen after switching out dead batteries. Turned out the service contract had expired and they couldn't charge my CC so there was no service plan to get the pics from. Soon as I updated the CC info I got good service again.

I have been pleased with my link evo. Pic quality out of any cell camera is not great, but it does tell you something is there. that's all I use it for...

Re: SPYPOINT link evo [Re: Texas buckeye] #7015792
12/29/17 05:19 PM
12/29/17 05:19 PM
Joined: Feb 2009
Posts: 5,232
Dallas
T
tannerlst Offline
THF Trophy Hunter
tannerlst  Offline
THF Trophy Hunter
T

Joined: Feb 2009
Posts: 5,232
Dallas
Originally Posted By: Texas buckeye
I have had that issue twice on my camera. First time was when I first set it up, was not getting a signal so I got a cell booster antenna and it solved the problem.

More recently I had the same thing happen after switching out dead batteries. Turned out the service contract had expired and they couldn't charge my CC so there was no service plan to get the pics from. Soon as I updated the CC info I got good service again.

I have been pleased with my link evo. Pic quality out of any cell camera is not great, but it does tell you something is there. that's all I use it for...


The Covert cell cams take good pictures

Last edited by tannerlst; 12/29/17 05:19 PM.
Re: SPYPOINT link evo [Re: tannerlst] #7015976
12/29/17 08:48 PM
12/29/17 08:48 PM
Joined: Feb 2013
Posts: 2,639
K
krmitchell Offline
Veteran Tracker
krmitchell  Offline
Veteran Tracker
K

Joined: Feb 2013
Posts: 2,639
Originally Posted By: tannerlst
Originally Posted By: Texas buckeye
I have had that issue twice on my camera. First time was when I first set it up, was not getting a signal so I got a cell booster antenna and it solved the problem.

More recently I had the same thing happen after switching out dead batteries. Turned out the service contract had expired and they couldn't charge my CC so there was no service plan to get the pics from. Soon as I updated the CC info I got good service again.

I have been pleased with my link evo. Pic quality out of any cell camera is not great, but it does tell you something is there. that's all I use it for...


The Covert cell cams take good pictures


And covert customer service is about as good as it comes. Love my coverts.

Previous Thread
Index
Next Thread


© 2004-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
UBB.threads™ 7.6.2