Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
seant8, Goldensammy, Steel185, tsutton, Atl89
61428 Registered Users
Top Posters
dogcatcher 80268
stxranchman 52092
RWH24 44568
rifleman 44011
BOBO the Clown 41737
BMD 40584
Big Orn 37484
bill oxner 36198
txshntr 34182
sig226fan (Rguns.com) 31063
facebook
Forum Stats
61428 Members
46 Forums
421362 Topics
5817823 Posts

Max Online: 16728 @ 03/25/12 08:51 AM
Topic Options
#6163853 - 01/31/16 08:26 PM $2 Buckmark repair
Slimpickin Offline
Tracker

Registered: 12/14/07
Posts: 864
Loc: DFW, Texas
I had "Stovepipe" issues with my Buckmark. Thought it was the ammo but found out the ejector was worn. Ordered a replacement ejector/spring and ran 50 (10 at a time)rapid fire rounds through without issue. Would have never known it was worn by looking at it. Apparently, when pulling the spent case, the weak ejector would release the casing prior to flipping it out to the side, causing the "Stovepipe".
You can find almost anything on the internet. My Buckmark was forgiven and now we are back on good terms!
_________________________

Top
#6163861 - 01/31/16 08:30 PM Re: $2 Buckmark repair [Re: Slimpickin]
QuitShootinYoungBucks Online   content
THF Trophy Hunter

Registered: 11/01/12
Posts: 7216
Loc: Lubbock, TX
Reckon it would work on my BIL's Challenger?
_________________________

Top
#6164481 - 02/01/16 10:31 AM Re: $2 Buckmark repair [Re: Slimpickin]
OkieDokie Offline
Tracker

Registered: 01/28/08
Posts: 833
Loc: southern OK
Tell me what's wrong with mine, ten round mag, ejects # 9 but doesn't feed #10. Have to rack slide to feed #10. I got a new mag and thought that would fix it but, that didn't fix problem. I have cleaned gun and that didn't help. Thanks for any help
David
_________________________
Maybe Today.
raptureready.com

Top
#6164495 - 02/01/16 10:39 AM Re: $2 Buckmark repair [Re: OkieDokie]
rickym Online   content
Extreme Tracker

Registered: 06/14/15
Posts: 4793
Loc: texas
Originally Posted By: OkieDokie
Tell me what's wrong with mine, ten round mag, ejects # 9 but doesn't feed #10. Have to rack slide to feed #10. I got a new mag and thought that would fix it but, that didn't fix problem. I have cleaned gun and that didn't help. Thanks for any help
David


Sounds like not enough tension on the spring, but if you already replaced the mag then I have no idea. Is the magazine staying firmly seated or is it sagging down after a few rounds?

Top
#6164913 - 02/01/16 03:27 PM Re: $2 Buckmark repair [Re: Slimpickin]
Slimpickin Offline
Tracker

Registered: 12/14/07
Posts: 864
Loc: DFW, Texas
Load your Mag and Manually operate your slide, CAREFULLY. Watch each round and position as it is feed. If only on the 10th round, I would think a spring issue on your Mag.
_________________________

Top
#6164919 - 02/01/16 03:29 PM Re: $2 Buckmark repair [Re: QuitShootinYoungBucks]
Slimpickin Offline
Tracker

Registered: 12/14/07
Posts: 864
Loc: DFW, Texas
Originally Posted By: QuitShootinYoungBucks
Reckon it would work on my BIL's Challenger?


Turn it slightly sideways to the left. If the round comes loose, when manually working the slide, just before ejection, he probably has the same issue.
_________________________

Top
#6165228 - 02/01/16 06:52 PM Re: $2 Buckmark repair [Re: Slimpickin]
OkieDokie Offline
Tracker

Registered: 01/28/08
Posts: 833
Loc: southern OK
Originally Posted By: Slimpickin
Load your Mag and Manually operate your slide, CAREFULLY. Watch each round and position as it is feed. If only on the 10th round, I would think a spring issue on your Mag.

I may try another new mag. The new mag would sometimes feed the last round. Is there a way to take the spring out and stretch it to get more spring tension?
_________________________
Maybe Today.
raptureready.com

Top
#6170113 - 02/04/16 08:35 PM Re: $2 Buckmark repair [Re: Slimpickin]
Slimpickin Offline
Tracker

Registered: 12/14/07
Posts: 864
Loc: DFW, Texas
Not sure on that one.
_________________________

Top



© 2004-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide