Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
jperez085, Reelbrothersfishingteam, flaboy71, HunterJoe, Pigmaster Yoda
63677 Registered Users
Top Posters
dogcatcher 87636
stxranchman 52793
bill oxner 46794
RKHarm24 44577
rifleman 44361
BOBO the Clown 43587
BMD 40886
Big Orn 37484
SnakeWrangler 35745
txshntr 35189
facebook
Forum Stats
63677 Members
45 Forums
453033 Topics
6260560 Posts

Max Online: 16728 @ 03/25/12 08:51 AM
Topic Options
#6100211 - 12/24/15 02:58 PM Duck boat question
Quackshack80 Offline
Light Foot

Registered: 12/12/15
Posts: 18
Guys I got a 77 evinrude that runs..somewhat. I got a carb kit, new fuel pump kit and all new gas lines it will run if you squeeze the bulb. Any idea what could make it not run when you don't keep squeezing the bulb

Top
#6100360 - 12/24/15 04:41 PM Re: Duck boat question [Re: Quackshack80]
clydeg Offline


Registered: 08/01/09
Posts: 26
Loc: Midlothian, TX
I'd suspect its the fuel pump. Did you already replace it and the lines?
_________________________

Top
#6100431 - 12/24/15 05:36 PM Re: Duck boat question [Re: Quackshack80]
Fooshman Offline
THF Celebrity

Registered: 07/26/06
Posts: 14041
Loc: Black Dog, Texas
I'd get rid of or replace the bulb first.
_________________________

Custom Crosses and Plaques

Top
#6101375 - 12/25/15 11:45 AM Re: Duck boat question [Re: Quackshack80]
aerangis Offline
Tracker

Registered: 09/05/08
Posts: 909
Loc: Nunya
Leak in the fuel line would be my first guess. 2nd, fuel pump.
_________________________
Do you ever get the feeling you're being watched? Because if you do, I'll stop doing it.

Top
#6101527 - 12/25/15 02:09 PM Re: Duck boat question [Re: Quackshack80]
Cooter II Offline
Green Horn

Registered: 08/20/06
Posts: 9
Anywhere there is a seal. Some years ago my gas cap rubber was bad, liked to never had found it.

Top
#6101838 - 12/25/15 07:07 PM Re: Duck boat question [Re: Quackshack80]
Central texas Offline
Woodsman

Registered: 01/30/15
Posts: 131
Gas line and bulb I would replace also

Top
#6102032 - 12/25/15 09:15 PM Re: Duck boat question [Re: Quackshack80]
pervis Offline
Tracker

Registered: 09/26/14
Posts: 712
Ok few things to check. Like stated above check or replace the bulb. Then replace the two fuel clips ie the ones from the line to the tank and the one from the line to the motor. I'm almost certain those are your problem. I had the same issue. Those clips are in the marine section at Walmart for around 5$ each. Then make sure your gas tank is vented when u are running. And other than that. Post up and il try to suggest more.

Top
#6102684 - 12/26/15 01:19 PM Re: Duck boat question [Re: Quackshack80]
Quackshack80 Offline
Light Foot

Registered: 12/12/15
Posts: 18
The bulb is brand new, I replaced everything in the summer and it ran great for trot lines but here comes duck season thinking it was in great working order. Get out and hunt a few times boat runs but you have to squeeze the bulb, I had replaced all the gaskets in the fuel pump and a new filter. New gas lines all the way thru and new gaskets and all new parts on the carb. But recently saw I was fouling the plugs. Today I'm replacing the plugs due to me breaking one and gonna put brand new gas and oil mix in it. Maybe water in the gas or too rich? I'm just trying to get it back and running so I don't use my bass boat...thanks again for all the help.

Top
#6102862 - 12/26/15 04:23 PM Re: Duck boat question [Re: Quackshack80]
Fooshman Offline
THF Celebrity

Registered: 07/26/06
Posts: 14041
Loc: Black Dog, Texas
If you are fouling the plugs it is too rich.

Did you replace the pump itself?
_________________________

Custom Crosses and Plaques

Top
#6103456 - 12/26/15 10:10 PM Re: Duck boat question [Re: Quackshack80]
Spacemonkey Offline
Pro Tracker

Registered: 12/03/09
Posts: 1229
Loc: North Texas
Is the tank vent open? When you did the carb did you replace the float?

Top
#6106518 - 12/28/15 04:07 PM Re: Duck boat question [Re: Quackshack80]
Quackshack80 Offline
Light Foot

Registered: 12/12/15
Posts: 18
Got her up and running, replaced plugs and a new tank of gas, guess I mixed two oils together or too much oil or even a bad batch of gas. Thanks for all the help you guys!!
You guys respond better than the TFF member, I appreciate it.

Top



© 2004-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide