Main Menu
Newest Members
LandLoan, Philjr1, Atexan, bhbeagles, 35whelen
60039 Registered Users
Top Posters
dogcatcher 76364
stxranchman 51856
RWH24 44568
rifleman 43694
BOBO the Clown 40886
BMD 40536
Big Orn 37484
txshntr 33520
bill oxner 31835
sig226fan ( 30456
Forum Stats
60039 Members
45 Forums
470985 Topics
6178846 Posts

Max Online: 16728 @ 03/25/12 08:51 AM
Topic Options
#5916561 - 09/07/15 10:46 AM Win 1300 pump problem
Javelin225ho Offline

Registered: 08/22/13
Posts: 121
Saturday, while on the dove field with my brother, my 1300 Winchester pump broke on me. The two spot welds on the slide had given way. Has any of you guys had this happen before? If so, did you reach out to Winchester? Did they help you or tell you too bad?

#5916823 - 09/07/15 02:21 PM Re: Win 1300 pump problem [Re: Javelin225ho]
Pro Tracker

Registered: 01/06/11
Posts: 1686
Loc: Northlake Tx
Wow ! My 1300 Win is over 25 yrs old and still performs great. That's really strange.

You Don't Have A PIG Problem If Ya Want to Charge $200.00

#5916909 - 09/07/15 03:40 PM Re: Win 1300 pump problem [Re: Javelin225ho]
toolman Offline

Registered: 02/22/09
Posts: 3671
Loc: Abilene, Tx.
I've seen it happen on several different guns as well as the action bars cracking alongside the welds. The action bars take a beating on pump guns. You should be able to get a replacement from Numrich's fairly cheap.
You don't get to be old by being stupid, but I made it to middle age!


© 2004-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide