Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
LADD3, Karl, the Greatest, Leonard Blackburn, TXSportsman82, old badge
63599 Registered Users
Top Posters
dogcatcher 87034
stxranchman 52562
bill oxner 46147
RWH24 44568
rifleman 44356
BOBO the Clown 43467
BMD 40835
Big Orn 37484
txshntr 35148
SnakeWrangler 34887
facebook
Forum Stats
63599 Members
45 Forums
451141 Topics
6233817 Posts

Max Online: 16728 @ 03/25/12 08:51 AM
Topic Options
#5916561 - 09/07/15 10:46 AM Win 1300 pump problem
Javelin225ho Offline
Woodsman

Registered: 08/22/13
Posts: 121
Saturday, while on the dove field with my brother, my 1300 Winchester pump broke on me. The two spot welds on the slide had given way. Has any of you guys had this happen before? If so, did you reach out to Winchester? Did they help you or tell you too bad?

Top
#5916823 - 09/07/15 02:21 PM Re: Win 1300 pump problem [Re: Javelin225ho]
THETEXAN Offline
Pro Tracker

Registered: 01/06/11
Posts: 1731
Loc: Northlake Tx
Wow ! My 1300 Win is over 25 yrs old and still performs great. That's really strange.
_________________________

You Don't Have A PIG Problem If Ya Want to Charge $200.00

Top
#5916909 - 09/07/15 03:40 PM Re: Win 1300 pump problem [Re: Javelin225ho]
toolman Offline


Registered: 02/22/09
Posts: 3676
Loc: Abilene, Tx.
I've seen it happen on several different guns as well as the action bars cracking alongside the welds. The action bars take a beating on pump guns. You should be able to get a replacement from Numrich's fairly cheap.
_________________________
You don't get to be old by being stupid, but I made it to middle age!

Top



© 2004-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide